Objective: To configure port-channel and associate it to vlan.
Servers will use Cisco-NXOS as their gateway and uplink to Internet. Server-switch have Layer 2 (access mode) connectivity to Cisco-NXOS router. (see Fig.1)
Fig.1
1. Configure the Vlan (interface vlan will be the server's gateway)
Cisco-NXOS#
configure
vlan 8
name Server-Farm
interface Vlan8
description Server Farm Vlan
no shutdown
ip address 192.168.8.1/24
2. Configure port-channel
interface port-channel10
description Port-channel to Server-Switch
switchport access vlan 8
3. Configure physical members
interface eth1/1
description Connection to Server-Switch fa0/1
switchport access vlan 8
channel-group 10 mode active
no shutdown
interface eth1/2
description Connection to Server-Switch fa2/0
switchport access vlan 8
channel-group 10 mode active
no shutdown
Verification and sample output:
Server1 = 192.168.8.20
Server2 = 192.16 8.8.21
ARP:
Cisco-NXOS# show ip arp vlan8
Flags: * - Adjacencies learnt on non-active FHRP router
+ - Adjacencies synced via CFSoE
# - Adjacencies Throttled for Glean
CP - Added via L2RIB, Control plane Adjacencies
PS - Added via L2RIB, Peer Sync
RO - Re-Originated Peer Sync Entry
D - Static Adjacencies attached to down interface
IP ARP Table
Total number of entries: 2
Address Age MAC Address Interface Flags
192.168.8.20 00:15:47 0011.abcd.ef00 Vlan8
192.168.8.21 00:15:47 0011.abcd.ef01 Vlan8
Ping:
Cisco-NXOS# ping 192.168.8.20 source 192.168.8.1
PING 192.168.8.20 (192.168.8.20) from 192.168.8.1: 56 data bytes
64 bytes from 192.168.8.20: icmp_seq=0 ttl=63 time=0.62 ms
64 bytes from 192.168.8.20: icmp_seq=1 ttl=63 time=0.441 ms
64 bytes from 192.168.8.20: icmp_seq=2 ttl=63 time=0.454 ms
64 bytes from 192.168.8.20: icmp_seq=3 ttl=63 time=0.54 ms
64 bytes from 192.168.8.20: icmp_seq=4 ttl=63 time=0.394 ms
--- 192.168.8.20 ping statistics ---
5 packets transmitted, 5 packets received, 0.00% packet loss
round-trip min/avg/max = 0.394/0.489/0.62 ms
Check Port-channel:
Cisco-NXOS# show int port-channel 10 | i Members
Members in this channel: Eth1/1, Eth1/2
Check Vlan:
Cisco-NXOS# show vlan
8 Server-Farm active Po10
Verify the traffic:
show int port-channel1
show int vlan8
show int eth1/1
show int eth1/2
Here's the Juniper version for this --> Configuring Port-Channel and VLAN in Juniper
No comments:
Post a Comment